DNS Issues

Incident Report for Netmatters

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 17:41 BST

Update

We are continuing to monitor for any further issues.
Posted Jun 10, 2025 - 08:41 BST

Monitoring

The upstream issue with our DNS provider has been resolved. We have confirmed with our provider that the service is back to normal.

We will continue to monitor the situation closely to ensure full stability. Thank you for your patience and understanding.
Posted Jun 10, 2025 - 08:39 BST

Investigating

We are aware of an upstream issue with one of our DNS providers.

We are currently in contact with the provider and working to resolve this as soon as possible.

We'll keep you informed as more information becomes available.
Posted Jun 09, 2025 - 11:52 BST
This incident affected: Managed DNS Platform.