The server and all associated websites are now back online. Functionality has been restored, and we will continue to monitor the server to make sure everything is working.
Posted Jul 04, 2026 - 08:17 BST
Investigating
We are aware that one of our hosting servers is currently offline; we are investigating the cause of the outage. We will update you once we have more information.
Posted Jul 04, 2026 - 07:44 BST
This incident affects: Shared Web/Email Hosting Platform.