Cloudflare incident, affecting a portion of hosted websites

Incident Report for Netmatters

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 09:24 GMT

Monitoring

Based on our observations and updates from Cloudflare, all services should now be restored. The latest update from Cloudflare is below, but we will continue to monitor the situation.

Any concerns, please reach out to us.


"""
Cloudflare services are currently operating normally. We are no longer observing elevated errors or latency across the network.

Our engineering teams continue to closely monitor the platform and perform a deeper investigation into the earlier disruption, but no configuration changes are being made at this time.

At this point, it is considered safe to re-enable any Cloudflare services that were temporarily disabled during the incident. We will provide a final update once our investigation is complete.
"""
Posted Nov 18, 2025 - 19:06 GMT

Identified

We are currently aware of an upstream outage impacting Cloudflare services. Please note that not all of our sites use Cloudflare, so not every site is affected. We are monitoring the situation closely.

Thank you for your patience.

If you are affected, Cloudflare are also publishing updates here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 12:01 GMT
This incident affected: Shared Web/Email Hosting Platform, Sysflow Managed Platform, and Managed DNS Platform.